Автор: Рубрики: Маркетинг Просмотрено: 315
WordPress сайты на старых версиях PHP станут уязвимыми в декабре 2018. Время обновить PHP!
09Ноя2018

С декабря 2018 года сайты на WordPress, которые используют PHP 5.6 and 7.0 перестанут получать обновление, что составляет 57,1% от общего числа сайтов на Водпресс. Патчи для безопасности сайтов не будут выпускаться на выше указанных версиях PHP.

Это может привести к уменьшению трафика и ухудшению поисковых позиций веб-сайтов WordPress, которые все еще используют эти старые версии PHP.

 

Что такое PHP?

PHP – это язык программирования, позволяющий создавать сайты. Существуют различные версии PHP, каждая из которых является улучшенной версией предыдущей. С созданием новых версий существует возможность обновления, для использования всех преимуществ новой версии пхп.

Когда закончатся обновления безопасности?

Обновления безопасности для PHP 5.6 заканчиваются 31 декабря 2018 года. Обновления безопасности и исправления для PHP 7.0 заканчиваются 3 декабря 2018 года.

Сколько сайтов столкнуться с проблемой безопасности?

Согласно официальной статистике 57,1% всех сайтов на WP используют PHP.

Почему заканчивается поддержка?

Поддержка безопасности для каждой версии запланирована на ограниченное количество лет, пока она не достигнет того, что называется “конец жизненного цикла” (End of Life (EOL)). Что означает отсутствия улучшений и обновлений для сайтов на WordPress, работающих со старыми версиями PHP, даже в случае обнаружения уязвимостей? Согласно официальному сайту PHP термин EOL означает:

“Релиз, который больше не поддерживается. Пользователям, которые все еще используют данную версию,следует как можно скорее обновится для избежания возникновений уязвимостей”.

Всем веб-сайтам настоятельно рекомендуется установить обновления до последней версии, так как повышается вероятность взлома.

Что случится, если не получится обновить PHP?

Все веб-сайты, которые не могут обновиться до последней версии PHP, будут небезопасными и уязвимыми для взлома после окончания поддержки версий 5.6 и 7.0. А это означает, что в случае нахождения уязвимостей CMS системы никто не будет заниматься устранением дыр в безопасности версии PHP в стадии EOL. Также множество плагинов и тем WordPress  перестанут работать.

Если у вас сайт написанный на WordPress, то вам стоит как можно скорее уточнить, какую версию PHP вы используете и по возможности обновить ее. Для этого обратитесь в техническую поддержку своего хостинг-провайдера.

Как проверить, какую версию PHP вы используете?

Наиболее простой способ это войти в панель управления хостингом и зайти в раздел связанный с PHP. Также существует много инструментов для проверки версии пхп онлайн, но мы рекомендуем проверять именно через панель управления хостингом. На хостинге от ГиперХост используются две популярные панели управления Cpanel и ISPmanager, проверить версию PHP можно в соответствующем разделе как на скриншотах:

в панеле управления сPanel

в панеле управления ISPmanager

 

Непосредственно в самом Вордпрессе есть плагины, которые могут подсказать вам, какую версию вы используете. Например, плагин WordPress phpinfo используется для определения версии PHP сайта. После определения версии PHP не забудьте удалить этот плагин.

Ну и самым простым методом определения версии PHP является обращение в нашу тех поддержку, мы можем точно сказать вам какую версию вы используете и помочь с ее обновлением.

 

Как обновиться с PHP 5.6/7.0 до последних версий?

  1. Сделайте резервную копию сайта

Прежде чем вносить какие-либо изменения стоит сделать резервную копию. Резервную копию можно создать используя плагин UpDraftPlus, самостоятельно через панель управления или написав в нашу тех поддержку.

  1. Проверьте совместимость плагинов

Проверьте или обновлены все плагины до последней версии. Последнее обновление плагина должно быть не более года. Если плагин давно не обновлялся, свяжитесь с автором плагина или найдите информацию о том, работает ли данный плагин с последней версией PHP 7.2.

Если плагин не совместим с данной версией, то его следует заменить на похожий, который поддерживает обновления и совместим с последней версией пхп. Плагины, которые не обновляются несут серьезный риск безопасности.

  1. Обновление версии PHP

Зайдите в панель управления хостингом cPanel или ISPmanager, зайдите раздел PHP и обновите версию PHP для вашего сайта. Если знаете, как это сделать напишите нам, мы всегда готовы помочь. Создайте тикет в разделе “Тикеты”, “Открыть новый тикет” выберете отдел тех поддержки и укажите, какая версия PHP вам нужна.

Сделайте безопасность частью вашего SEO продвижения

Вопросы безопасности обычно не являются частью SEO, так как напрямую не влияют на ранжирование. В то же время, если сайт взломают, то трафик на ваш сайт снижается, что влияет на СЕО непосредственно. Поэтому не стоит ждать форс мажоров, а добавить еще один пункт проверки в ваш СЕО лист – проверка безопасности сайта.

Перевод с сайта searchenginejournal.com

 

316 раз(а) 5 Сегодня просмотрено раз(а)
  • Владимир Дот

    Ну всё не так уж и критично! Жили мы без обновлений лет 5 и ничего, всё было нормально. Главное сайт грамотно настроить, и никто к вам не заберётся. Если же решитесь обновить платформу, то тут тоже ничего страшного, всё легко настраивается.

    • Марина Семёнова

      От смены пхп хуже точно не будет. А обновления всё же полезны, баги и дыры в системе закрывать как то же надо?!

  • Марина Семёнова

    Они там случайно не объявляли, сколько ещё будет поддерживаться версия пхп 7.2? И планируются ли в скором времени новые обновы?